Pogoplug E02 - install Arch Linux ARM

$ ssh root@10.0.0.111
The authenticity of host '10.0.0.111 (10.0.0.111)' can't be established.
RSA key fingerprint is 9f:d7:dd:b5:ef:0d:a1:c0:f7:56:e4:5e:22:f6:5c:3d.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '10.0.0.111' (RSA) to the list of known hosts.
root@10.0.0.111's password: root
[root@alarm ~]# pacman -Sy linux-kirkwood linux-kirkwood-headers ntp yaourt base-devel nano wget
:: Synchronizing package databases...
 core                     163.2 KiB   293K/s 00:01 [####################] 100%
 extra                   1892.2 KiB  1554K/s 00:01 [####################] 100%
 community                  2.1 MiB  1189K/s 00:02 [####################] 100%
 alarm                     27.7 KiB  27.1M/s 00:00 [####################] 100%
 aur                       65.4 KiB   696K/s 00:00 [####################] 100%
warning: ntp-4.2.6.p5-18 is up to date -- reinstalling
:: There are 25 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file
   7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff
   14) gzip  15) libtool  16) m4  17) make  18) pacman  19) patch
   20) pkg-config  21) sed  22) sudo  23) texinfo  24) util-linux  25) which


Enter a selection (default=all): <enter>
warning: file-5.16-1 is up to date -- reinstalling
warning: findutils-4.4.2-5 is up to date -- reinstalling
warning: gawk-4.1.0-2 is up to date -- reinstalling
warning: gettext-0.18.3.2-1 is up to date -- reinstalling
warning: grep-2.16-1 is up to date -- reinstalling
warning: groff-1.22.2-5 is up to date -- reinstalling
warning: gzip-1.6-1 is up to date -- reinstalling
warning: pacman-4.1.2-5.1 is up to date -- reinstalling
warning: sed-4.2.2-3 is up to date -- reinstalling
warning: texinfo-5.2-2 is up to date -- reinstalling
warning: util-linux-2.24.1-1 is up to date -- reinstalling
warning: which-2.20-6 is up to date -- reinstalling
warning: nano-2.2.6-2 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
:: linux-kirkwood and linux are in conflict. Remove linux? [y/N] y

Packages (42): cloog-0.18.1-2  gc-7.4.0-1  guile-2.0.9-1  isl-0.12.2-1
               libatomic_ops-7.2.e-1  libidn-1.28-2  libltdl-2.4.2-12
               libmpc-1.0.2-2  linux-3.1.10-30 [removal]  package-query-1.2-2
               yajl-2.0.4-2  autoconf-2.69-1  automake-1.14.1-1
               binutils-2.24-1  bison-3.0.2-1  fakeroot-1.20-1  file-5.16-1
               findutils-4.4.2-5  flex-2.5.37-1  gawk-4.1.0-2  gcc-4.8.2-7
               gettext-0.18.3.2-1  grep-2.16-1  groff-1.22.2-5  gzip-1.6-1
               libtool-2.4.2-12  linux-kirkwood-3.13.2-1
               linux-kirkwood-headers-3.13.2-1  m4-1.4.17-1  make-4.0-2
               nano-2.2.6-2  ntp-4.2.6.p5-18  pacman-4.1.2-5.1  patch-2.7.1-2
               pkg-config-0.28-1  sed-4.2.2-3  sudo-1.8.9.p5-1  texinfo-5.2-2
               util-linux-2.24.1-1  wget-1.15-1  which-2.20-6  yaourt-1.3-1

Total Download Size:    60.45 MiB
Total Installed Size:   218.76 MiB
Net Upgrade Size:       156.29 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 linux-kirkwood-3.13...    17.5 MiB  2.70M/s 00:06 [####################] 100%
 linux-kirkwood-head...     5.7 MiB  4.77M/s 00:01 [####################] 100%
 pacman-4.1.2-5.1-arm     562.6 KiB  5.44M/s 00:00 [####################] 100%
 gettext-0.18.3.2-1-arm  1710.8 KiB  4.90M/s 00:00 [####################] 100%
 gawk-4.1.0-2-arm         841.8 KiB  2.41M/s 00:00 [####################] 100%
 m4-1.4.17-1-arm          148.6 KiB  1955K/s 00:00 [####################] 100%
 autoconf-2.69-1-any      577.9 KiB  3.55M/s 00:00 [####################] 100%
 automake-1.14.1-1-any    584.2 KiB  4.46M/s 00:00 [####################] 100%
 binutils-2.24-1-arm        3.6 MiB  2.87M/s 00:01 [####################] 100%
 bison-3.0.2-1-arm        466.5 KiB  5.77M/s 00:00 [####################] 100%
 sed-4.2.2-3-arm          117.5 KiB  3.59M/s 00:00 [####################] 100%
 util-linux-2.24.1-1-arm 1625.0 KiB  4.84M/s 00:00 [####################] 100%
 fakeroot-1.20-1-arm       57.5 KiB  18.7M/s 00:00 [####################] 100%
 file-5.16-1-arm          197.8 KiB  6.66M/s 00:00 [####################] 100%
 findutils-4.4.2-5-arm    321.0 KiB  7.64M/s 00:00 [####################] 100%
 flex-2.5.37-1-arm        771.7 KiB  5.67M/s 00:00 [####################] 100%
 libmpc-1.0.2-2-arm        53.3 KiB  17.3M/s 00:00 [####################] 100%
 isl-0.12.2-1-arm         324.9 KiB  7.21M/s 00:00 [####################] 100%
 cloog-0.18.1-2-arm        57.5 KiB  18.7M/s 00:00 [####################] 100%
 gcc-4.8.2-7-arm           16.4 MiB  1885K/s 00:09 [####################] 100%
 grep-2.16-1-arm          192.3 KiB  6.06M/s 00:00 [####################] 100%
 groff-1.22.2-5-arm      1637.7 KiB  4.49M/s 00:00 [####################] 100%
 gzip-1.6-1-arm            71.2 KiB  17.4M/s 00:00 [####################] 100%
 libltdl-2.4.2-12-arm     143.3 KiB  6.09M/s 00:00 [####################] 100%
 libtool-2.4.2-12-arm     270.5 KiB  6.00M/s 00:00 [####################] 100%
 texinfo-5.2-2-arm       1108.1 KiB  5.18M/s 00:00 [####################] 100%
 make-4.0-2-arm           360.2 KiB  5.67M/s 00:00 [####################] 100%
 patch-2.7.1-2-arm         68.8 KiB  11.2M/s 00:00 [####################] 100%
 pkg-config-0.28-1-arm     27.7 KiB  27.1M/s 00:00 [####################] 100%
 sudo-1.8.9.p5-1-arm      721.1 KiB  4.99M/s 00:00 [####################] 100%
 which-2.20-6-arm          12.0 KiB  11.7M/s 00:00 [####################] 100%
 nano-2.2.6-2-arm         290.9 KiB  6.17M/s 00:00 [####################] 100%
 ntp-4.2.6.p5-18-arm      400.0 KiB  5.74M/s 00:00 [####################] 100%
 yajl-2.0.4-2-arm          30.1 KiB  14.7M/s 00:00 [####################] 100%
 libatomic_ops-7.2.e...    55.8 KiB  13.6M/s 00:00 [####################] 100%
 gc-7.4.0-1-arm           192.6 KiB  7.84M/s 00:00 [####################] 100%
 guile-2.0.9-1-arm          2.8 MiB  6.04M/s 00:00 [####################] 100%
 libidn-1.28-2-arm        181.6 KiB  5.54M/s 00:00 [####################] 100%
 wget-1.15-1-arm          486.3 KiB  5.05M/s 00:00 [####################] 100%
 package-query-1.2-2-arm   19.9 KiB  0.00B/s 00:00 [####################] 100%
 yaourt-1.3-1-any          49.8 KiB  16.2M/s 00:00 [####################] 100%
(41/41) checking keys in keyring                   [####################] 100%
(41/41) checking package integrity                 [####################] 100%
(41/41) loading package files                      [####################] 100%
(41/41) checking for file conflicts                [####################] 100%
(42/42) checking available disk space              [####################] 100%
(1/1) removing linux                               [####################] 100%
( 1/41) installing linux-kirkwood                  [####################] 100%
>>> Updating module dependencies. Please wait ...
depmod: ERROR: Module 'hci_vhci' has devname (vhci) but lacks major and minor information. Ignoring.
**********************************************************************
WARNING! This kernel requires a newer U-Boot than many devices such as
         the Dockstar and Pogoplug v2 originally came with. If you do
         not have an updated version, your system WILL NOT BOOT.
**********************************************************************
Optional dependencies for linux-kirkwood
    crda: to set the correct wireless channels of your country
( 2/41) installing linux-kirkwood-headers          [####################] 100%
( 3/41) reinstalling ntp                           [####################] 100%
( 4/41) reinstalling pacman                        [####################] 100%
( 5/41) installing yajl                            [####################] 100%
( 6/41) installing package-query                   [####################] 100%
( 7/41) reinstalling gettext                       [####################] 100%
( 8/41) installing yaourt                          [####################] 100%
Optional dependencies for yaourt
    aurvote: vote for favorite packages from AUR
    customizepkg: automatically modify PKGBUILD during install/upgrade
    rsync: retrieve PKGBUILD from official repositories
( 9/41) reinstalling gawk                          [####################] 100%
(10/41) installing m4                              [####################] 100%
(11/41) installing autoconf                        [####################] 100%
(12/41) installing automake                        [####################] 100%
(13/41) installing binutils                        [####################] 100%
(14/41) installing bison                           [####################] 100%
(15/41) reinstalling sed                           [####################] 100%
(16/41) reinstalling util-linux                    [####################] 100%
(17/41) installing fakeroot                        [####################] 100%
(18/41) reinstalling file                          [####################] 100%
(19/41) reinstalling findutils                     [####################] 100%
(20/41) installing flex                            [####################] 100%
(21/41) installing libmpc                          [####################] 100%
(22/41) installing isl                             [####################] 100%
(23/41) installing cloog                           [####################] 100%
(24/41) installing gcc                             [####################] 100%
(25/41) reinstalling grep                          [####################] 100%
(26/41) reinstalling groff                         [####################] 100%
(27/41) reinstalling gzip                          [####################] 100%
(28/41) installing libltdl                         [####################] 100%
(29/41) installing libtool                         [####################] 100%
(30/41) reinstalling texinfo                       [####################] 100%
(31/41) installing libatomic_ops                   [####################] 100%
(32/41) installing gc                              [####################] 100%
(33/41) installing guile                           [####################] 100%
(34/41) installing make                            [####################] 100%
(35/41) installing patch                           [####################] 100%
Optional dependencies for patch
    ed: for patch -e functionality
(36/41) installing pkg-config                      [####################] 100%
(37/41) installing sudo                            [####################] 100%
(38/41) reinstalling which                         [####################] 100%
(39/41) reinstalling nano                          [####################] 100%
(40/41) installing libidn                          [####################] 100%
(41/41) installing wget                            [####################] 100%
Optional dependencies for wget
    ca-certificates: HTTPS downloads [installed]

[root@alarm ~]# 

No comments:

Post a Comment